# Copyright (C) 2022 LingYun IoT System Studio
|
# Released under the GPLv2 license
|
#
|
# SPDX-License-Identifier: GPLv2
|
#
|
|
SUMMARY = "Linux Kernel provided and supported by LingYun IoT System Studio"
|
DESCRIPTION = "Linux Kernel provided and supported by LingYun with focus on IGKBoard"
|
|
LICENSE = "GPLv2"
|
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
|
|
require recipes-kernel/linux/linux-yocto.inc
|
|
SRCBRANCH = "lf-5.15.y"
|
KERNEL_SRC = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
|
KBRANCH = "${SRCBRANCH}"
|
SRC_URI = "${KERNEL_SRC}"
|
|
# https://source.codeaurora.org/external/imx/linux-imx/tag/?h=lf-5.15.32-2.0.0
|
SRCREV = "fa6c3168595c02bd9d5366fcc28c9e7304947a3d"
|
LOCALVERSION = "-lf-5.15.32-2.0.0"
|
|
LINUX_VERSION = "5.15.32"
|
KERNEL_DANGLING_FEATURES_WARN_ONLY = "1"
|
|
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
|
SRC_URI += " file://linux-imx-igkboard.patch "
|
PATCHTOOL = "patch"
|
|
do_copy_defconfig:append() {
|
cp ${S}/arch/arm/configs/igkboard_defconfig ${WORKDIR}/defconfig
|
cp ${S}/arch/arm/configs/igkboard_defconfig ${B}/.config
|
}
|