SUMMARY = "Linux kernel hello module"
|
DESCRIPTION = "${SUMMARY}"
|
LICENSE = "GPLv2"
|
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6"
|
|
inherit module
|
|
FILESEXTRAPATHS:prepend := "${THISDIR}/src:"
|
SRC_URI = "file://Makefile \
|
file://hello.c \
|
"
|
|
S = "${WORKDIR}"
|
|
# The inherit of module.bbclass will automatically name module packages with
|
# "kernel-module-" prefix as required by the oe-core build environment.
|
|
EXTRA_OEMAKE += "-C ${STAGING_KERNEL_BUILDDIR} M=${S}"
|
EXTRA_OEMAKE:append:task-install = "-C ${STAGING_KERNEL_DIR} M=${S}"
|