| | |
| | | # Copyright (C) 2022 LingYun IoT System Studio |
| | | # Released under the GPLv2 license |
| | | # |
| | | # SPDX-License-Identifier: GPLv2 |
| | | # |
| | | |
| | | SUMMARY = "Linux Kernel provided and supported by LingYun IoT System Studio" |
| | | DESCRIPTION = "Linux Kernel provided and supported by LingYun with focus on IGKBoard" |
| | | |
| | | LICENSE = "GPLv2" |
| | | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;md5=801f80980d171dd6425610833a22dbe6" |
| | | |
| | | require recipes-kernel/linux/linux-yocto.inc |
| | | |
| | | SRCREV = "a11753a89ec610768301d4070e10b8bd60fde8cd" |
| | | SRCBRANCH = "lf-5.15.y" |
| | | KERNEL_SRC = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}" |
| | | KBRANCH = "${SRCBRANCH}" |
| | | SRC_URI = "${KERNEL_SRC}" |
| | | |
| | | # https://source.codeaurora.org/external/imx/uboot-imx/tag/?h=lf-5.10.52-2.1.0 |
| | | SRCREV = "1c0116f3da250c5a52858c53efb8b38c0963f477" |
| | | LOCALVERSION = "-lf-5.10.52-2.1.0" |
| | | |
| | | LINUX_VERSION = "5.10.52" |
| | | KERNEL_DANGLING_FEATURES_WARN_ONLY = "1" |
| | | |
| | | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" |
| | | SRC_URI += " file://linux-imx-igkboard.patch " |
| | | SRC_URI += " file://linux-imx-lf-5.10.52-2.1.0.patch " |
| | | PATCHTOOL = "patch" |
| | | |
| | | do_copy_defconfig_append() { |