From c6d260b5008cd38e7dbda0c6f61489d6dfb286c5 Mon Sep 17 00:00:00 2001
From: guowenxue <guowenxue@gmail.com>
Date: Sat, 20 Jul 2024 16:38:05 +0800
Subject: [PATCH] Patch:IGKBoard-IMX8MP: Add OV5640 camera support

---
 yocto/meta-igkboard/images/yocto-image-full.bb |   12 +++++++-----
 1 files changed, 7 insertions(+), 5 deletions(-)

diff --git a/yocto/meta-igkboard/images/yocto-image-full.bb b/yocto/meta-igkboard/images/yocto-image-full.bb
index a437d61..d08d1f2 100644
--- a/yocto/meta-igkboard/images/yocto-image-full.bb
+++ b/yocto/meta-igkboard/images/yocto-image-full.bb
@@ -8,12 +8,10 @@
 #IMAGE_ROOTFS_EXTRA_SPACE = "512000"
 
 inherit extrausers
-# Create the password hash with following command on host:
-# >> mkpasswd -m sha256crypt password -S abcd6789
-# Remember to escape the character $ in the resulting hash
 
-# Set the root password:
-#PASSWD="\$5\$abcd6789\$Vuv1aLz04ZwhxgsB3lOQbwy1XUS6PJ.8h2A7.9HoUd3"
+# Set the root password:  >> mkpasswd -m sha256crypt 123456 -S abcd6789
+# Remember to escape the character $ in the resulting hash
+#PASSWD="\$5\$abcd6789\$2ayD.ZPdq5xejNiyE3XC3qCpkGZ.brSE5H0zSECVBSB"
 EXTRA_USERS_PARAMS = "\
     usermod -p '${PASSWD}' root; \
 "
@@ -23,6 +21,8 @@
     hwcodecs \
     ssh-server-openssh \
     package-management \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'weston', \
+       bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11-base x11-sato', '', d), d)} \
 "
 
 CONFLICT_DISTRO_FEATURES = "directfb"
@@ -45,6 +45,7 @@
 
 CORE_IMAGE_EXTRA_INSTALL_BASE += " \
     kernel-modules hello-app hello-mod \
+    rtl8188fu rtl8723du \
     firmwared linux-firmware \
     powertop tzdata ppp vim \
     xz lrzsz rsync dos2unix \
@@ -63,6 +64,7 @@
     e2fsprogs-mke2fs e2fsprogs-resize2fs \
     cryptodev-module openssl-bin \
     libsocketcan can-utils canutils \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'weston-xwayland xterm', '', d)} \
 "
 
 # For machine igkboard-imx6ull

--
Gitblit v1.9.1